Excel para Gestores – Sem mistérios – Parte Final

Excel para Gestores – Sem mistérios – Parte Final

Neste último post da série de Excel sem mistérios para Gestores, vamos falar de funções do Excel:

Funções 

 Já havíamos discutido este assunto anteriormente, mas agora daremos uma ênfase maior, para que não haja dúvidas, relembrando, todas as funções do Excel utilizam uma sintaxe em comum, para digitar qualquer cálculo é necessário iniciar com o símbolo de igual “=”.  

 Este símbolo define que tudo o que será digitado ali deverá ser buscado na biblioteca de funções. 

 Você pode utilizar além destas fórmulas já prontas no Excel, trabalhar com os chamados operadores matemáticos básicos, muito comum em qualquer calculadora moderna, vejamos: 

 

Função  Operador  Exemplo  Resultado 
Potenciação  =10^2  100 
Multiplicação  =6*3  18 
Divisão  =8/4 
Soma  =19+15  34 
Subtração  =10-3 

 

Existe uma ordem especifica de utilização destes operadores matemáticos, importante que você saiba que ordem é esta. Então para montar uma fórmula deve-se observar a regra matemática para as prioridades das operações. Importante que você saiba que a separação entre um operador e outro pode ser através do caracter parentêse “( )”, se na fórmula não colocarmos parênteses “( )”  o Excel irá aplicar a regra matemática das prioridades. 

 Primeiro será considerado a potenciação, depois a multiplicação, divisão, soma e subtração. 

 Observe no exemplo a seguir que usaremos as mesmas operações, mas pode-se obter resultados diferentes. 

 =  4 + 5  * 3     - o resultado será  19

= (4 + 5) * 5    - o resultado será   45

 Isso porque, quando usamos parênteses, este passa a ter prioridade sobre as demais operações. 

 Fórmulas absolutas ou relativas 

 No Excel existem dois tipos de fórmulas que podemos trabalhar, as chamadas fórmulas absolutas e relativas. A diferença básica está quando reutilizamos estas em nossas células. 

 Fórmulas Relativas [Símbolo] As fórmulas mudam quando copiamos para outra célula. 

Fórmulas Absolutas [Símbolo]As fórmulas não mudam quando copiamos para outra célula. 

Por exemplo, quando copiamos uma fórmula =A2*B2 para as linhas A3 e B3, abaixo o Excel entende que as fórmulas devem ser relativas ou seja, mudam de acordo com as linhas. No exemplo usado =A2*B2 sendo relativas, mudam para =A3*B3 e assim por diante. 

 Mas, quando colocamos o símbolo de $ na fórmula, tudo muda, o chamado endereço da célula passa a ser fixo, ou seja, absoluto, antes de copiar deve-se usar o símbolo $  na fórmula que queremos copiar. 

Ex.: Na fórmula anterior, =A2*B2 queremos que quando copiar para as linhas abaixo o endereço B2 permaneça absoluto, ou fixo. 

 Fazemos então da seguinte forma: 

 =A2*B$2 

 Notem que o símbolo $ está antes do número 2 que identifica a linha. 

 Depois de copiado, as fórmulas ficam assim: 

 =A2*B$2 

=A3*B$2 

=A4*B$2 

=A5*B$2 

 Note, a informação no endereço B2 ficou fixo, não se alterou como anteriormente, como no exemplo da fórmula relativa. O efeito é o mesmo quando copiamos uma fórmula para outras colunas, ou seja, toda vez que desejamos fixar (ancorar) um determinado valor no Excel,  devemos colocar o símbolo $ na fórmula na frente da letra que identifica a coluna que deve permanecer fixa. 

 Podemos variar a utilização do simbolo de $, fixando linha e coluna ao mesmo tempo, ou apenas linha ou apenas coluna. Quando usamos o contexto de fórmulas relativas, por exemplo =A10*A11, quando copiamos para as outras colunas, ficam assim: 

 =B10*B11 

=C10*C11 

=D10*D11 

Se colocarmos o símbolo $ antes do A10, da seguinte forma =$A10*A11, depois de copiado, fica assim: 

=$A10*B2 

=$A10*C2 

=$A10*D2 

 Para que você fixe linha e coluna ao mesmo tempo, basta colocar o símbolo duas vezes na informação da fórmula, fixar a coluna e a linha usa-se =$A$10*A2, pois assim, quando copiamos esta fórmula para baixo ou para qualquer lugar na planilha, o endereço $A$10 sempre ficará fixo ou melhor absoluto. 

 Funções especiais 

  FUNÇÃO CONDICIONAL SE 

 O Excel, possui diversas funções não matemáticas, uma das que mais utilizamos e de grande destaque é a função (comando) SE, esta é capaz de testar uma determinada condição, seja cálculo ou não, que permita tomar uma decisão, vejamos: 

Por exemplo, em uma planilha há um campo chamado Vendas (G1), Aumentaremos em 20% o preço de determinado filme, caso as vendas ultrapassarem R$1.000,00 reais, caso contrário daremos um desconto de 10%. 

 Inicialmente na célula G2 iniciasse as informações das vendas até a célula G20. Vamos criar uma nova informação na célula H1 chamado PREÇO REAJUSTADO, onde colocaremos os novos valores, ou seja, vamos incluir a fórmula para calcular o valor das vendas. 

               =SE(CONDIÇÃO;VERDADEIRO;FALSO

=SE(G2>1000;G2*1,20;G2-(G2*0,1))    

Primeiro testamos SE G2 for maior que 1000. 

Logo após, vem o primeiro ponto e vírgula (  ;  ) onde consta a ação que deve tomar caso o teste seja verdadeiro. 

 Após o segundo ponto e vírgula (   ) deve constar a ação caso o teste seja falso. 

 Para verdadeiro ou falso podem ser usadas fórmulas, palavras e até mesmo outra condição, que chamamos de condição encadeada, ou seja, podemos colocar expressões caso uma determinada condição seja satisfeita. 

 =SE(G2>1000;"Aumento nas vendas";"Queda nas vendas") 

Importante que as palavras devem estar entre aspas ( “”). 

Neste exemplo deve aparecer a frase Aumento nas vendas se o teste for verdadeiro, caso contrário, se for falso deve aparecer a frase Queda nas vendas

 Você pode incrementar sua condição com o uso dos conectores OU e E, junto ao comando SE

 OU e E JUNTO COM O SE 

 Agora podemos selecionar determinados dados para que o cálculo faça sentido, então vamos trabalhar com a coluna C, vamos aplicar o cálculo de incremento de 20% apenas aos filmes Drama ou Ação

  =SE(OU(C2="Drama"; C2="Ação");G2*1,2;G2-(G2*0,1)) 

 Note que as condições do OU estão separadas por virgulas, isso é fundamental, caso contrário não irá funcionar. Pode-se pôr várias opções. Para a condição ser verdadeira, qualquer uma das opções serve, Drama ou Ação

 A opção OU na fórmula está isolada por parêntese.  OU(C2="Drama";C2="Ação"). Somente depois é que vem o primeiro ponto e vírgula onde constará a opção verdadeira e logo após, no segundo ponto e vírgula, a opção falsa. 

 JUNTO COM O SE 

 Agora vamos utilizar o conector E que permite que uma ação seja realizada caso as mesmas sejam verdadeiras, vejamos: 

 =SE(E(C2="Drama";G2>800);"Filmes drama valorizados";"Filmes drama alugados abaixo do esperado"

 Conforme havia afirmado, para a condição ser verdadeira é necessário que as condições dentro do conector E sejam ambas verdadeiras, ou seja,  na célula tem que haver ao mesmo tempo o tipo do filme igual a  “Drama” e o valor das vendas seja maior que 800 reais. Diferente do OU onde qualquer opção poderia ser verdadeira. 

Clique para conhecer o curso de Excel na Aprenda Virtual

 

Nenhum Comentário

Escrever um Comentário